Jump to content
Website open but under construction ×

Battlefield 4 fps drop, stuttering and lag fix


Recommended Posts





First you will need to go to your root BF4 folder ,

For example:

C:\Program Files (x86)\Origin Games\Battlefield 4


Next we are going to go to the direct x folder. Find DXSETUP , right click and run as admin.

Located here:

C:\Program Files (x86)\Origin Games\Battlefield 4\__Installer\directx\redist


Next we are going to re-install MS visual C++ Run both vcredist_x64 and vcredist_x86

Located here:

C:\Program Files (x86)\Origin Games\Battlefield 4\__Installer\vc\vc2012Update3\redist




Now back to the root folder , C:\Program Files (x86)\Origin Games\Battlefield 4


Here we are going to create a custom user.cfg file. To do this , right click an empty spot

on the desktop, select new, select Text Document . Right click on the Text Document and select rename. Rename it to user.cfg. Open it up and copy and paste these lines to it and save.


WorldRender.TransparencyShadowmapsEnable 0

WorldRender.MotionBlurEnable 0

WorldRender.MotionBlurForceOn 0

WorldRender.MotionBlurFixedShutterTime 0

WorldRender.MotionBlurMax 0

WorldRender.MotionBlurQuality 0

WorldRender.MotionBlurMaxSampleCount 0

WorldRender.SpotLightShadowmapEnable 0

WorldRender.SpotLightShadowmapResolution 256

WorldRender.LightTileCsPathEnable 0

RenderDevice.ForceRenderAheadLimit 0

PostProcess.DynamicAOEnable 0

PerfOverlay.DrawFps 0

GameTime.MaxVariableFps 59.99




Note: that the second to last line is to view fps while in game when set to PerfOverlay.DrawFps 1

The last line can have a number as high as 200 depending on what frames per second your pc can push. Setting this to , GameTime.MaxVariableFps 59.99 is recommended to keep a stable

fps rate. But if you think it can keep 100 fps stable then you can try that. 

After your done copy the user.cfg into the root folder 

C:\Program Files (x86)\Origin Games\Battlefield 4




Next we deal with the CPU 


First , if you know how to disable hyper threading in the bios then try that.

If not , google your "motherboard" and "disable HT" 


Now to ensure all cpu cores are dedicated to the game we are going to unpark them. HaHa whats that... well Windows 7 and 8 use a feature that idles or parks cores to save power when running windows. Its a green thing I guess. Its not a big issue in Windows 8 but when combined with disabling hyper threading you notice a much smoother game. At least I did .. so here what you do 


There are instructions and a download for a simple utility here



I have used this myself and can assure you it is 100% safe. Scan for yourself.

Use this to unpark your cores. Once you run this you will see that all but one 

core is parked. Follow instructions to unpark all cores, then restart your computer.


If you did this and disabled hyper threading you will now have 100% dedicated ghz from the cpu running your game on all cores. This is what you want, you do not want windows managing how much CPU to conserve for a slightly lower power bill. Your a gamer and you want performance. 







Nvidia GTX 600 and 700 series Graphics cards , this next step is optional but is consistent with

the previous step. These cards ramp up and down their clock rates depending on demand. 

Dynamic clock values can cause a bit of lag. I recommend getting evga Precision X And enabling kboost on the video card.

MSI Afterburner 


1) Using the kboost option lock's the cards clock speed to its optimized over clock rate.

Your screen will black out for a second , that is normal. Now your video card has 100%

dedicated power that is overclocked by the manufacture so it is safe. Then Next ...


2) Open up nvidia control panel my right clicking on desktop. Go to manage 3d settings, to the right on the program settings tab select Battlefield 4. Scroll down to "Power management mode" and select "Prefer maximum performance" Then select apply and close . 


  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
Holy Hanna!!


Moth'r fuk'r!!!


Omg! Really? 


Do what I do. Don't fuk'n play with Nvidia!


Just say'n.  :tongue:




Oh Boy, Seems Like an AMD fanboy here............. That's OK though :bouncing:


On a side note, I play on two different machines (when I have a water cooling issue), Both have Different CPU's and GPU's(GTX 970 and a GTX760) I can run everything on Ultra and I have no problems! I don't think its specific to Nvidia owners, their are countless CPU and GPU combo's out there!

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...